I'm posting a cry for help here too.

KJ

Moderator: Board of Directors

Post Reply
User avatar
03renegade
Newbie
Posts: 16
Joined: Sat Jul 05, 2008 1:26 pm
Location: Brooklyn, MD
Contact:

I'm posting a cry for help here too.

Post by 03renegade » Thu Jan 01, 2009 4:33 pm

I have an 03 Libby, when in 2 wheel drive the part time light is on when I put it in 4 high the light goes out, in 4 low it works like it should.
"Let me guess, you picked out yet another colorful box with a crank that I'm expected to turn and turn until OOP! big shock, a jack pops out and you laugh and the kids laugh and the dog laughs and I die a little inside"

User avatar
96XJKhris
Active Member
Active Member
Posts: 320
Joined: Sun Jan 08, 2006 4:39 pm
Location: Frederick MD
Contact:

Re: I'm posting a cry for help here too.

Post by 96XJKhris » Thu Jan 01, 2009 6:12 pm

grounding problem or a short in a sensor im guessing thats what it sounds like to me.
Its not a scratch... Its a scar
"XJ 84-01... Two Million+ can't be wrong...
Go square or go home!"

User avatar
ReneDave
Active Member
Active Member
Posts: 2290
Joined: Thu May 17, 2007 12:11 pm
Location: 'naptown

Re: I'm posting a cry for help here too.

Post by ReneDave » Thu Jan 01, 2009 9:01 pm

Replace the position sensor and change the transfer case fluid (RTF+4) while you're at it. The sensor is on the top of the transfer case by the input shaft.
"I like when things catch fire and explode, which means I do not have your best interests in mind."

User avatar
03renegade
Newbie
Posts: 16
Joined: Sat Jul 05, 2008 1:26 pm
Location: Brooklyn, MD
Contact:

Re: I'm posting a cry for help here too.

Post by 03renegade » Fri Jan 02, 2009 7:56 pm

Thanks guys I really appreciate the advice.
"Let me guess, you picked out yet another colorful box with a crank that I'm expected to turn and turn until OOP! big shock, a jack pops out and you laugh and the kids laugh and the dog laughs and I die a little inside"

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest